You must be logged in to post messages.
Please login or register

General and Strategy Discussions
Moderated by GoSailing

Hop to:    
Welcome! You are not logged in. Please Login or Register.12 replies
Empires Heaven » Forums » General and Strategy Discussions » Not starting
Bottom
Topic Subject:Not starting
Igor Kool
Member
posted 03-10-09 09:51 AM EDT (US)         
Hey I just installed the game on my pc and I can't seem to play it. It worked fine before since I played it ages ago, but now it just doesnt start.

When I try to play it, I click on the icon and I get the game mouse and black screen (as if it's about to start) but then it crushes and goes back to windows.

Can any one please help? I have Russian legal version of the game, no patches or mods installed.

Thanks in advance.
AuthorReplies:
GoSailing
EEH Seraph
posted 03-10-09 10:08 AM EDT (US)     1 / 12       
The general first step for game crashes is a reinstall, but before you do that I wonder if you possibly have too many programs running in the background? When a game refuses to load, its often because there isn't enough RAM available for it to load. If this is the case, closing some other processes should fix it. If this isn't, then a reinstall is probably your best bet.

"It seems to me the humour of Sails is so dry you could strike a match on it and it would be the humour that caught fire." - Friend of Old
Igor Kool
Member
posted 03-10-09 10:23 AM EDT (US)     2 / 12       
Ok thanks for the tip. I have 2 gigs of RAM so I doubt it's the problem. I will reinstall it now and tell you what I get.

Hope it works! Fingers crossed! And thank you for your help. Will keep you posted.

Edit: Ok I have reinstalled the game but for some reason I get the same problem. I get the "Empires Dawn of The modern world" picture, then I get the "Loading", game mouse, black screen and then it goes back to windows.

I am not sure if this might be the problem, but I cant's seem to install game properly. Before from what I remember, when auto run started is said either "Game" or "Install". But now it just says game all the time.

I had to re install game by deleting it from windows and installing it by using installation button on cd, not the autorun.

Sorry if this is too complicated.. Probably something with my pc anyway...

[This message has been edited by Igor Kool (edited 03-10-2009 @ 10:49 AM).]

Rotaretilbo
Member
(id: Brandon Rebuga)
posted 03-10-09 04:14 PM EDT (US)     3 / 12       
This may not be likely, but I recall having a game with high graphics requirements, and because my on board graphics card did not meet those requirements, I got the same problem you describe. It would show me the little game picture, the screen would go black as if loading the game, and then it would crash back to desktop.

The reason I say this isn't likely is because Empires doesn't have the highest graphics requirements. My on board card ran it just fine. But you may want to check just in case. Perhaps your card has been corrupted or something like that. I just figured I'd throw this in, since the problem you describe is similar to one I had with a newer game.

"Also, I'm no clearer on what WIFOM is really, although I gather it's something to do with Thymole being gay..." -Sassenach
"I don't lie in my claims and I don't intend to." -WeeMicky
"OH MY GOD A DINOSAUR" -Peter Fallon
Igor Kool
Member
posted 03-10-09 07:36 PM EDT (US)     4 / 12       
Rotaretilbo, I think you might be right actually. I had my pc upgraded at least twice, and I had changed graphics card...

It is just I remember that the game worked fine on my 16 mb graphics card before, but it is weird that it doesnt work on my 512 mb card now. I have nvidia, but that shouldnt be the problem since when I had 256 mb nvidia card from what I remember it worked.

So can it be that my card is... too high for the game to run? Because I had few games not working on my pc just because my card was "too new".

Also, this might be too much to ask, but is there anyway to solve it? Like with patches, or do I have to change card drivers? Because last time I downloaded nvidia drivers, I actually found out that I had 2 drivers conflicting, making pc working slower. Don't want to make that mistake again

Thanks for the help guys! Really appreciate it.
GoSailing
EEH Seraph
posted 03-10-09 07:51 PM EDT (US)     5 / 12       
I ran this years ago with a 2 MB onboard graphics card.
It is just I remember that the game worked fine on my 16 mb graphics card before, but it is weird that it doesnt work on my 512 mb card now. I have nvidia, but that shouldnt be the problem since when I had 256 mb nvidia card from what I remember it worked.
You know, I didn't think about this earlier (shame on me) but you should see if there are available driver updates for your graphics card. They will be downloadable from nVidia's website.

If that doesn't work, though I suspect it will, you should post here and the moderator there will help you out. I honestly haven't heard of a software problem he hasn't figured out. Not to guarantee anything, but hes definitely the guy to help you if the drivers don't fix it.

"It seems to me the humour of Sails is so dry you could strike a match on it and it would be the humour that caught fire." - Friend of Old

[This message has been edited by GoSailing (edited 03-10-2009 @ 07:57 PM).]

BlakeII7
Member
posted 03-10-09 10:30 PM EDT (US)     6 / 12       
I once had a similar thing happen, most games don't run in my native resolution, so the game will "auto-correct" when it loads, I had my res. locked, and the game could not change it, so it would go black, and then back to my desktop, unfortunately, I don't remember how I fixed it, just that it was locked. I don't think that I had to download anything to fix it, it was just a setting that was conflicting, I was/am still running XP pro.

The only other thing I can think of is a language setting that's screwing it up, but other than that I'm drawing a blank. Hope it helps.

If you are a Christian and not ashamed of it, put this is your signature and spread his good news.
92% of teens have moved on to rap. If you are part of the 8% who still listen to real music, copy and paste this into your sig.
Igor Kool
Member
posted 03-11-09 05:52 AM EDT (US)     7 / 12       
Alright then, I will try updating my drivers for the graphics card. Thank you very much everyone for your help, I will try to do everything including fixing my resolution screen.

But the problem is that last time I downloaded driver update from nvidia website, I had the conflict with 2 drivers. But I have nvidia card. OK sorry I am making it worse than it is sorry.

Does any one know what driver updates are suitable for my card? I have NVIDIA GeForce 8500 GT (GeForce 8500 GT) but it doesnt like nvidia drivers for some reason. Sorry once again for making things complicated. I very appreciate the help everyone!

Thank you for finding out why the game doesnt seem to work!
GoSailing
EEH Seraph
posted 03-11-09 10:04 AM EDT (US)     8 / 12       
http://www.nvidia.com/object/winxp_182.08_whql.html

Theres the link to download the drivers you will want. They were updated a week ago, so they're definitely recent.

"It seems to me the humour of Sails is so dry you could strike a match on it and it would be the humour that caught fire." - Friend of Old
Igor Kool
Member
posted 03-11-09 12:34 PM EDT (US)     9 / 12       
Ok thanks a lot! I will download them right now. And sorry if this might be too hard, but can I delete them if they don't work? Or downgrade it to what I had...

Let's hope they work and no conflict is between my drivers.
GoSailing
EEH Seraph
posted 03-11-09 06:16 PM EDT (US)     10 / 12       
If you haven't deleted the setup for your old drivers or you have the disc that came with the graphics card then, if the drivers don't work at all (but they shouldn't cause problems or nVidia shouldn't/wouldn't have released them) you can uninstall them and reinstall your new ones.

"It seems to me the humour of Sails is so dry you could strike a match on it and it would be the humour that caught fire." - Friend of Old
Igor Kool
Member
posted 03-17-09 03:29 PM EDT (US)     11 / 12       
Hey everyone, sorry for not posting for a while. I have downloaded the drivers for my video card but it didn't seem to help at all....

Thanks anyway, I guess I will have to go to the moderator you told me to ask. Thank you very much for trying to help everyone!
GoSailing
EEH Seraph
posted 03-17-09 06:07 PM EDT (US)     12 / 12       
No big deal about the wait. Goodluck with PCDania finding a solution.

"It seems to me the humour of Sails is so dry you could strike a match on it and it would be the humour that caught fire." - Friend of Old
You must be logged in to post messages.
Please login or register

Hop to:    

Empires Heaven | HeavenGames